Развлекаемся с inter-AS MPLS VPN...

Возникла тут необходимость подружить два сегмента сети с разными IGP по mpls, причём и AS в сегментах тоже разные.
После внимательного вкуривания
http://http://www.cisco.com/en/US/docs/ios/12_1t/12_1t5/feature/guide/InterAS.html#wp1083643
и
http://www.cisco.com/en/US/tech/tk436/tk428/technologies_configuration_example09186a0080094472.shtml
Родилась следующая схема:



Всё оказалось весьма тривиально...
Основное - no bgp default route-target filter
Конфиги ниже.

autostart = False
[localhost:7200]
workingdir = /tmp
udp = 10000
[[7200]]
image = /home/rmavrichev/.c7200-advipservicesk9-mz.122-33.SRE2/C7200-AD.BIN
idlepc = 0x627700bc
ghostios = True
[[ROUTER isp1pe1]]
console = 2007
idlepc = 0x62771c64
f0/0 = isp1pe2 f0/0
x = -140.0
y = 114.0
[[ROUTER isp2pe1]]
console = 2011
f0/0 = isp2pe2 f0/1
x = 284.0
y = 116.0
[localhost:7201]
workingdir = /tmp
udp = 10100
[[7200]]
image = /home/rmavrichev/.c7200-advipservicesk9-mz.122-33.SRE2/C7200-AD.BIN
idlepc = 0x62771c8c
ghostios = True
[[ROUTER isp2pe2]]
console = 2009
idlepc = 0x62771000
f0/0 = isp1pe2 f0/1
f0/1 = isp2pe1 f0/0
x = 195.0
y = -30.0
[[ROUTER isp1pe2]]
console = 2008
f0/0 = isp1pe1 f0/0
f0/1 = isp2pe2 f0/0
x = -44.0
y = -29.0
[GNS3-DATA]
m11 = 1.0
m22 = 1.0
[[NOTE 1]]
text = mpBGP
x = 95.0
y = -48.5
rotate = 0
color = "#323232"
[[NOTE 2]]
text = as65535
x = 194.0
y = 84.5
rotate = 0
color = "#323232"
[[NOTE 3]]
text = as65050
x = -41.0
y = 86.5
rotate = 0
color = "#323232"
[[NOTE 4]]
text = igp1
x = -115.0
y = 10.5
rotate = 0
color = "#323232"
[[NOTE 5]]
text = igp2
x = 292.0
y = 10.5
rotate = 0
color = "#323232"
[[SHAPE 1]]
type = ellipse
x = 177.0
y = -28.0
width = 200.0
height = 200.0
rotate = 0
border_style = 2
[[SHAPE 2]]
type = ellipse
x = -161.0
y = -27.0
width = 200.0
height = 200.0
rotate = 0
border_style = 2

!
! Last configuration change at 17:33:35 UTC Tue Feb 8 2011
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname isp1pe1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
ip vrf MNGM
rd 200:700
route-target export 200:700
route-target import 200:700
route-target import 200:300
route-target import 200:301
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
mpls label protocol ldp
clns routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.98.33.1 255.255.255.255
!
interface Loopback30
description MNGM-loopback
ip vrf forwarding MNGM
ip address 172.16.16.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.2.128.1 255.255.255.252
ip router isis 1
speed auto
duplex auto
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface FastEthernet0/1
no ip address
speed auto
duplex auto
!
router isis 1
net 49.0010.0100.9812.8001.00
is-type level-2-only
ispf level-2
metric-style wide level-2
passive-interface Loopback0
!
router bgp 65050
template peer-policy iBGP
next-hop-self
send-community both
exit-peer-policy
!
template peer-session iBGP_new
remote-as 65050
update-source Loopback0
exit-peer-session
!
bgp router-id 10.98.33.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp deterministic-med
bgp update-delay 1
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 1 20
neighbor 10.98.33.2 remote-as 65050
neighbor 10.98.33.2 inherit peer-session iBGP_new
!
address-family ipv4
no synchronization
redistribute connected
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.98.33.2 activate
neighbor 10.98.33.2 send-community extended
neighbor 10.98.33.2 inherit peer-policy iBGP
exit-address-family
!
address-family ipv4 vrf MNGM
no synchronization
redistribute connected
exit-address-family
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname isp1pe2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
ip vrf MNGM
rd 200:700
route-target export 200:700
route-target import 200:700
route-target import 200:300
route-target import 200:301
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
mpls label protocol ldp
clns routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.98.33.2 255.255.255.255
!
interface Loopback30
description MNGM-loopback
ip vrf forwarding MNGM
ip address 172.16.16.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.2.128.2 255.255.255.252
ip router isis 1
speed auto
duplex auto
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface FastEthernet0/1
descr To-ISP2-PE2
ip address 192.168.0.1 255.255.255.252
speed auto
duplex auto
!
router isis 1
net 49.0010.0100.9812.8002.00
is-type level-2-only
ispf level-2
metric-style wide level-2
passive-interface Loopback0
!
router bgp 65050
template peer-policy iBGP
next-hop-self
send-community both
exit-peer-policy
!
template peer-session iBGP_new
remote-as 65050
update-source Loopback0
exit-peer-session
!
bgp router-id 10.98.33.2
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
bgp deterministic-med
bgp update-delay 1
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 1 20
neighbor 10.98.33.1 remote-as 65050
neighbor 10.98.33.1 inherit peer-session iBGP_new
neighbor 192.168.0.2 remote-as 65535
!
address-family ipv4
no synchronization
redistribute connected
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.98.33.1 activate
neighbor 10.98.33.1 send-community extended
neighbor 10.98.33.1 inherit peer-policy iBGP
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 send-community extended
exit-address-family
!
address-family ipv4 vrf MNGM
no synchronization
redistribute connected
exit-address-family
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

!
! Last configuration change at 17:50:48 UTC Tue Feb 8 2011
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname isp2pe1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
ip vrf MNGM
rd 200:700
route-target export 200:700
route-target import 200:700
route-target import 200:300
route-target import 200:301
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
mpls label protocol ldp
clns routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.97.33.1 255.255.255.255
!
interface Loopback30
description MNGM-loopback
ip vrf forwarding MNGM
ip address 172.17.17.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.2.128.1 255.255.255.252
ip router isis 1
speed auto
duplex auto
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
interface FastEthernet0/1
no ip address
speed auto
duplex auto
!
router isis 1
net 49.0010.0100.9712.8001.00
is-type level-2-only
ispf level-2
metric-style wide level-2
passive-interface Loopback0
!
router bgp 65535
template peer-policy iBGP
next-hop-self
send-community both
exit-peer-policy
!
template peer-session iBGP_new
remote-as 65535
update-source Loopback0
exit-peer-session
!
bgp router-id 10.97.33.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp deterministic-med
bgp update-delay 1
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 1 20
neighbor 10.97.33.2 remote-as 65535
neighbor 10.97.33.2 inherit peer-session iBGP_new
!
address-family ipv4
no synchronization
redistribute connected
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.97.33.2 activate
neighbor 10.97.33.2 send-community extended
neighbor 10.97.33.2 inherit peer-policy iBGP
exit-address-family
!
address-family ipv4 vrf MNGM
no synchronization
redistribute connected
exit-address-family
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

!
! Last configuration change at 17:50:54 UTC Tue Feb 8 2011
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname isp2pe2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
ip vrf MNGM
rd 200:700
route-target export 200:700
route-target import 200:700
route-target import 200:300
route-target import 200:301
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
mpls label protocol ldp
clns routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.97.33.2 255.255.255.255
!
interface Loopback30
description MNGM-loopback
ip vrf forwarding MNGM
ip address 172.17.17.2 255.255.255.255
!
interface FastEthernet0/0
descr To-ISP1-PE2
ip address 192.168.0.2 255.255.255.252
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 10.2.128.2 255.255.255.252
ip router isis 1
speed auto
duplex auto
mpls ip
isis circuit-type level-2-only
isis network point-to-point
!
router isis 1
net 49.0010.0100.9712.8002.00
is-type level-2-only
ispf level-2
metric-style wide level-2
passive-interface Loopback0
!
router bgp 65535
template peer-policy iBGP
next-hop-self
send-community both
exit-peer-policy
!
template peer-session iBGP_new
remote-as 65535
update-source Loopback0
exit-peer-session
!
bgp router-id 10.97.33.2
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
bgp deterministic-med
bgp update-delay 1
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
timers bgp 1 20
neighbor 10.97.33.1 remote-as 65535
neighbor 10.97.33.1 inherit peer-session iBGP_new
neighbor 192.168.0.1 remote-as 65050
!
address-family ipv4
no synchronization
redistribute connected
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.97.33.1 activate
neighbor 10.97.33.1 send-community extended
neighbor 10.97.33.1 inherit peer-policy iBGP
neighbor 192.168.0.1 activate
neighbor 192.168.0.1 send-community extended
exit-address-family
!
address-family ipv4 vrf MNGM
no synchronization
redistribute connected
exit-address-family
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end